<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<!-- goog fonts -->
	<link href="https://fonts.googleapis.com/css2?family=Noto+Sans:ital,wght@0,400;0,700;1,400;1,700&display=swap" rel="stylesheet">
	<link href="https://fonts.googleapis.com/css2?family=Noto+Sans+JP:wght@300&display=swap" rel="stylesheet">
	<link href="https://fonts.googleapis.com/css2?family=Noto+Serif:wght@400;700&display=swap" rel="stylesheet">

	<!-- font awesome -->
	<link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.10.0/css/all.css" integrity="sha384-AYmEC3Yw5cVb3ZcuHtOA93w35dYTsvhLPVnYs9eStHfGJvOvKxVfELGroGkvsg+p" crossorigin="anonymous"/>

	<!-- slick slider -->
	 <link rel="stylesheet" type="text/css" href="//cdn.jsdelivr.net/jquery.slick/1.6.0/slick.css"/>
        <!-- Add the slick-theme.css if you want default styling -->
        <link rel="stylesheet" type="text/css" href="//cdn.jsdelivr.net/jquery.slick/1.6.0/slick-theme.css"/>

			<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
										div.heateor_sss_vertical_sharing  a.heateor_sss_button_instagram span{background:#CF1117!important;}div.heateor_sss_floating_follow_icons_container a.heateor_sss_button_instagram span{background:#CF1117;}
							div.heateor_sss_vertical_sharing a.heateor_sss_button_instagram span:hover{background:#000000!important;}div.heateor_sss_floating_follow_icons_container a.heateor_sss_button_instagram span:hover{background:#000000;}
				.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							background-color: #CF1117!important;
				background: #CF1117!important;
							color: #ffffff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
							background-color: #000000!important;
				background: #000000!important;
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}		</style>
		<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Mississippi State guard Iverson Molinar not selected in NBA draft - The Dispatch</title>
	<link rel="canonical" href="https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Mississippi State guard Iverson Molinar not selected in NBA draft - The Dispatch" />
	<meta property="og:description" content="Iverson Molinar hoped to parlay a strong junior season at Mississippi State into a professional draft selection. But Molinar’s decision to leave school early didn’t" />
	<meta property="og:url" content="https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/" />
	<meta property="og:site_name" content="The Dispatch" />
	<meta property="article:published_time" content="2022-06-24T04:31:14+00:00" />
	<meta property="og:image" content="https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10.jpg" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="682" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Theo DeRosa" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://cdispatch.com/#website","url":"https://cdispatch.com/","name":"The Dispatch","description":"News for Columbus, Starkville and the Golden Triangle Area","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://cdispatch.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/#primaryimage","inLanguage":"en-US","url":"https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10.jpg","contentUrl":"https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10.jpg","width":1024,"height":682,"caption":"Iverson Molinar was not selected in Thursday's NBA draft. The junior guard left Mississippi State after averaging 17.5 points during the 2021-22 season. Photo by: Austin Perryman/Mississippi State athletics"},{"@type":"WebPage","@id":"https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/#webpage","url":"https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/","name":"Mississippi State guard Iverson Molinar not selected in NBA draft - The Dispatch","isPartOf":{"@id":"https://cdispatch.com/#website"},"primaryImageOfPage":{"@id":"https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/#primaryimage"},"datePublished":"2022-06-24T04:31:14+00:00","dateModified":"2022-06-24T04:31:14+00:00","author":{"@id":"https://cdispatch.com/#/schema/person/58ff1c62572ce244549211d412c944a8"},"breadcrumb":{"@id":"https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/"]}]},{"@type":"BreadcrumbList","@id":"https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://cdispatch.com/"},{"@type":"ListItem","position":2,"name":"Mississippi State guard Iverson Molinar not selected in NBA draft"}]},{"@type":"Person","@id":"https://cdispatch.com/#/schema/person/58ff1c62572ce244549211d412c944a8","name":"Theo DeRosa","image":{"@type":"ImageObject","@id":"https://cdispatch.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e7b48e2e4c56d3746cb2d641201d5c53?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/e7b48e2e4c56d3746cb2d641201d5c53?s=96&d=mm&r=g","caption":"Theo DeRosa"},"description":"Theo DeRosa reports on Mississippi State sports for The Dispatch. Follow him on Twitter at @Theo_DeRosa.","url":"https://cdispatch.com/author/theo-derosa/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Dispatch &raquo; Feed" href="https://cdispatch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dispatch &raquo; Comments Feed" href="https://cdispatch.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Dispatch &raquo; Mississippi State guard Iverson Molinar not selected in NBA draft Comments Feed" href="https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/feed/" />
<script>
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdispatch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://cdispatch.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='cookie-law-info-css'  href='https://cdispatch.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css?ver=2.1.2' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://cdispatch.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css?ver=2.1.2' media='all' />
<link rel='stylesheet' id='search-filter-plugin-styles-css'  href='https://cdispatch.com/wp-content/plugins/search-filter-pro/public/assets/css/search-filter.min.css?ver=2.5.11' media='all' />
<link rel='stylesheet' id='understrap-styles-css'  href='https://cdispatch.com/wp-content/themes/commercial_dispatch/css/theme.min.css?ver=.1617941203' media='all' />
<link rel='stylesheet' id='weather-styles-css'  href='https://cdispatch.com/wp-content/themes/commercial_dispatch/simple-weather/css/simple-weather.css?ver=.1618427362' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://cdispatch.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.38' media='all' />
<script data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=5.9.3' id='broadstreet-cdn-js'></script>
<script src='https://cdispatch.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://cdispatch.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script id='cookie-law-info-js-extra'>
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"1","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":"","button_1_button_colour":"#cf1117","button_1_button_hover":"#a60e12","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":"","button_2_hidebar":"","button_3_button_colour":"#3566bb","button_3_button_hover":"#2a5296","button_3_link_colour":"#fff","button_3_as_button":"1","button_3_new_win":"","button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#333333","button_4_as_button":"","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"inherit","header_fix":"","notify_animate_hide":"1","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#333333","show_once_yn":"","show_once":"10000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/cdispatch.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://cdispatch.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=2.1.2' id='cookie-law-info-js'></script>
<script id='search-filter-plugin-build-js-extra'>
var SF_LDATA = {"ajax_url":"https:\/\/cdispatch.com\/wp-admin\/admin-ajax.php","home_url":"https:\/\/cdispatch.com\/","extensions":[]};
</script>
<script src='https://cdispatch.com/wp-content/plugins/search-filter-pro/public/assets/js/search-filter-build.min.js?ver=2.5.11' id='search-filter-plugin-build-js'></script>
<script src='https://cdispatch.com/wp-content/plugins/search-filter-pro/public/assets/js/chosen.jquery.min.js?ver=2.5.11' id='search-filter-plugin-chosen-js'></script>
<link rel="https://api.w.org/" href="https://cdispatch.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cdispatch.com/wp-json/wp/v2/posts/205400" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cdispatch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdispatch.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://cdispatch.com/?p=205400' />
<link rel="alternate" type="application/json+oembed" href="https://cdispatch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcdispatch.com%2Fsports%2F2022-06-23%2Fmississippi-state-guard-iverson-molinar-not-selected-in-nba-draft%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cdispatch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcdispatch.com%2Fsports%2F2022-06-23%2Fmississippi-state-guard-iverson-molinar-not-selected-in-nba-draft%2F&#038;format=xml" />
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','college-sports','sports','sports','mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["college-sports","sports","sports","mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft","post"],"url":"mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6341);
 });</script><meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-title" content="The Dispatch - News for Columbus, Starkville and the Golden Triangle Area">
<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://cdispatch.com/wp-content/uploads/2020/10/cropped-dispatch-red-d-logo-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdispatch.com/wp-content/uploads/2020/10/cropped-dispatch-red-d-logo-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdispatch.com/wp-content/uploads/2020/10/cropped-dispatch-red-d-logo-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdispatch.com/wp-content/uploads/2020/10/cropped-dispatch-red-d-logo-2-270x270.png" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-7266681-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-7266681-1');
</script>
<!--	<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://whineattempt.com/v2yugPzkizb_2Ls-EvELpa2LmcAnxPQ25fySns8gYM7YSd37cRjrGWythNgT2hTnSecQXdEEqvg",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o.admiral=o.admiral||t})(window);!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");
</script>
-->
<style>
@media only screen and (min-width:768px) {
.featured-col{
        width: calc(100% - 360px);
        flex: none;
        padding:0 30px;
}

#search-results-sidebar,
div#sidebar,
div#sidebar-2 {
        width: 360px;
    display: block;
    max-width: 360px;
    box-sizing: border-box;
    padding: 0 30px;
    flex: none;
}

}
.author-link a{
	text-decoration:none !important;
}
.aJVLc6uP {
display:none !important;
}
.searchandfilter2 {
padding-right:16px;
}
input.sf-input-text-alt{
    border:solid 1px transparent;
transition:all .25s linear;
    width: 30px;
    transition: all .25s linear;
    background: url(/wp-content/themes/commercial_dispatch/img/search-icon.png);
    background-size: 20px;
    background-repeat: no-repeat;
    background-position: right 4px top 4px;
    padding:4px;
    padding-right:23px;
    font-size:.85rem;
}

input.sf-input-text-alt:focus {
width:80px;
border: solid 1px #f0eeee;
    outline: none;
}

.sf-input-text-alt::-webkit-input-placeholder {
    color:transparent;
}
.sf-input-text-alt:focus::-webkit-input-placeholder {
font-weight: normal;
    font-family: "Open Sans";
    color: rgb(0,0,0);
    font-size: 12px;
    text-shadow: none;
    opacity: 0.85;
}
.top-nav-row{
	align-items:center;
}
#top-search-form{
	display:none !important;
}
@media only screen and (min-width:370px){
        input.sf-input-text-alt:focus {
                width:100px;
        }
}
@media only screen and (min-width:420px){
        input.sf-input-text-alt:focus {
                width:120px;
        }
}
@media only screen and (min-width:480px){
        input.sf-input-text-alt:focus {
                width:160px;
        }
}
@media only screen and (min-width:586px){
	input.sf-input-text-alt:focus {
                width:200px;
        }
}
@media only screen and (min-width:768px){
	#top-search-form{
		display:inline-block !important;
	}
	#mobile-top-search-form {
		display:none;
	}
}
.temp-imperial:after {
        content:'\00B0';
    }

@media only screen and (min-width:992px) {
	 .middle-logo{
                display:none;
        }
    }
    header .middle-logo img{
	width:100%;
	max-width:140px;
	height:auto;
    }

    @media (max-width:575px) {
	.col-xs-4 {
    -webkit-box-flex: 0;
    -webkit-flex: 0 0 33.33333%;
    -moz-box-flex: 0;
    -ms-flex: 0 0 33.33333%;
    flex: 0 0 33.33333%;
    max-width: 33.33333%;
	}
    }
    @media (max-width:991px) {

	.hidden-md-down {
		display:none !important;
	}
    }
     /* breaking news banner */
.breaking-news {
	height: auto;
	width:100%;
	background-color: #000;
	padding:10px 0px;
	margin-top: -1px;
	z-index: 8;
	position: relative;
}
.breaking-news-title {
	font-family: "Noto Sans", sans-serif;
	font-style: normal;
	font-weight: bold;
	font-size: 33px;
	line-height: 45px;
	letter-spacing: 0.03em;
	margin-right:10px;
	color:#fff;
}
.breaking-news-descript {
	font-family: "Noto Sans", sans-serif;
	font-style: normal;
	font-weight: normal;
	font-size: 20px;
	line-height: 41px;
	letter-spacing: 0.03em;
	color:#fff;
	text-align: center;
	margin: auto;
}
@media only screen and (max-width:600px) {
	.breaking-news-title {
		font-size: 23px;
		line-height: 25px;
	}
	.breaking-news-descript {
		font-size:17px;
		line-height: 21px;
	}
}

</style>
<!--
<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://whineattempt.com/v2hkmY3D19xjWTtduqCLxAzPv6mvt_xlkE2FeTny-PkrdheZcFdlEvXn4W_Nyw61E",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o.admiral=o.admiral||t})(window);!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");;;;!(function(n,t,i,u,e,o,r){function a(n){if(n){var u=(n.data||{}).__uspapiCall;u&&t[i](u.command,u.version,(function(t,i){n.source.postMessage({__uspapiReturn:{returnValue:t,success:i,callId:u.callId}},"*")}))}}!(function f(){if(!window.frames[u]){var t=n.body;if(t){var i=n.createElement("iframe");i.style.display="none",i.name=u,t.appendChild(i)}else setTimeout(f,5)}})();var s={getUSPData:function(n,t){return n!==1?t&&t(null,!1):t&&t({version:null,uspString:null},!1)}};function c(n,t,i){return s[n](t,i)}c.v=1,"function"!=typeof t[i]&&(t[i]=t[i]||c,t.addEventListener?t.addEventListener("message",a,!1):t.attachEvent&&t.attachEvent("onmessage",a)),o=n.createElement(e),r=n.getElementsByTagName(e)[0],o.src="https://whineattempt.com/v2efjOGfZfR-B471N011qBEhPblbc6rzTUetwXhAn70i35-CFlO2rxgvJNWmry_spCxFt7pYZSDhV-Nsauw",r.parentNode.insertBefore(o,r)})(document,window,"__uspapi","__uspapiLocator","script");</script>
-->
<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://whineattempt.com/v2yugPzkizb_2Ls-EvELpa2LmcAnxPQ25fySns8gYM7YSd37cRjrGWythNgT2hTnSecQXdEEqvg",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o.admiral=o.admiral||t})(window);!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");

</script>
</head>
<body>

<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.498039215686" /><feFuncG type="table" tableValues="0 0.498039215686" /><feFuncB type="table" tableValues="0 0.498039215686" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.549019607843 0.988235294118" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.717647058824 0.254901960784" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.278431372549" /><feFuncB type="table" tableValues="0.592156862745 0.278431372549" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.647058823529" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.780392156863 1" /><feFuncG type="table" tableValues="0 0.949019607843" /><feFuncB type="table" tableValues="0.352941176471 0.470588235294" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.650980392157 0.403921568627" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.447058823529 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.0980392156863 1" /><feFuncG type="table" tableValues="0 0.662745098039" /><feFuncB type="table" tableValues="0.847058823529 0.419607843137" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>

<div class="site" id="page">
 <a class="skip-link sr-only sr-only-focusable" href="#content">Skip to content</a>

    <header id="main-header" style="opacity:0;">
	    <div class="top container-fluid">

		    <div class="container">
				<div class="row top-nav-row">
					<div class="left-side col-xs-4 col-sm-4 col-md-4 col-lg-9">
						<form action="/search/" method="get" class="searchandfilter2" id="top-search-form" autocomplete="off">
							<input placeholder="search..." name="_sf_s" class="sf-input-text-alt" type="text" value="" title="">
						</form>
						<a class="hamburger-toggle" href="#">
							<span class="sections-label">Sections</span>
							<i class="fas fa-bars"></i>
							<i class="fa fa-times" aria-hidden="true"></i>
						</a>
						<nav class="quickview-menu">
																						<ul>
																	<li>
										<a href="https://cdispatch.com/obituaries/">Obituaries</a>
									</li>
																	<li>
										<a href="https://cdispatch.com/eedition/">eEdition</a>
									</li>
																	<li>
										<a href="https://cdispatch.com/popular-content/">Popular Content</a>
									</li>
																	<li>
										<a href="https://cdispatch.com/tips/">Submit a Tip</a>
									</li>
																</ul>
													</nav>
					</div>
						 
					<div class="middle-logo col-xs-4 col-sm-4 col-md-4 text-center">
<a href="/">
                                <img src="https://cdispatch.com/wp-content/themes/commercial_dispatch/img/dispatch_blk.png">
                            </a>
			</div>
                    <div class="right-side col-xs-4 col-sm-4 col-md-4 col-lg-3">

					<form action="/search/" method="get" class="searchandfilter2" id="mobile-top-search-form" autocomplete="off">
                                                        <input placeholder="search..." name="_sf_s" class="sf-input-text-alt" type="text" value="" title="">
						</form>
				<div class="login-subscribe">
				</div>
					</div>
				</div>
			</div>
		</div>
	    <div class="middle container-fluid">
		    <div class="container">
				<nav class="sections-menu">
				    	<div class="mobile-top container">
						<div class="mobile-login-subscribe login-subscribe">
                                		</div>
					</div>
					<div class="mobile-bottom container">
						<div class="row">
							<section class="date-wrapper col-6 col-sm-6" style="opacity:0">
							    June 24th, 2022							</section>
							<section class="weather-wrapper col-6 col-sm-6"></section>
						</div>
				    </div>
				    <div class="column-wrapper container">
																			<ul class="quick-links">
							    <li class="no-link">QUICK LINKS</li>
															<li>
									<a href="https://cdispatch.com/obituaries/">Obituaries</a>
								</li>
															<li>
									<a href="https://cdispatch.com/eedition/">eEdition</a>
								</li>
															<li>
									<a href="https://cdispatch.com/popular-content/">Popular Content</a>
								</li>
															<li>
									<a href="https://cdispatch.com/tips/">Submit a Tip</a>
								</li>
														</ul>
												<ul>
																																								<li>
										<a href="https://cdispatch.com/news/">News</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/columbus-lowndes-county/">Columbus &amp; Lowndes County</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/starkville-oktibbeha-county/">Starkville &amp; Oktibbeha County</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/west-point-clay-county/">West Point &amp; Clay County</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/area/">Area</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/state/">State</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/national/">National</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/news/business/">Business</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="https://cdispatch.com/sports/">Sports</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/sports/high-school-sports/">High School Sports</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/sports/college-sports/">College Sports</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/sports/local-columns-sports/">Local Columns</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="https://cdispatch.com/opinions/">Opinions</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/opinions/local-columns/">Local Columns</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/opinions/letters-to-the-editor/">Letters to the Editor</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/opinions/roses-thorns/">Roses &amp; Thorns</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/opinions/dispatch-editorials/">Dispatch Editorials</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="https://cdispatch.com/obituaries/">Obituaries</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="https://cdispatch.com/lifestyles/">Lifestyles</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/lifestyles/columns-lifestyle/">Columns</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/lifestyles/entertainment/">Entertainment</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/lifestyles/food/">Food</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/lifestyles/transitions-announcements/">Transitions &amp; Announcements</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/lifestyles/community/">Community</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/lifestyles/religion/">Religion</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="http://ads.cdispatch.com/">Classifieds</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="/gallery/">Photo Galleries</a>
									</li>
																											</ul>
										<ul>
																		<li>
										<a href="https://cdispatch.com/public-records/">Public Records</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/public-records/building-permits/">Building Permits</a>
									</li>
																										<li>
										<a href="https://cdispatch.com/public-records/marriages-divorces/">Marriages &amp; Divorces</a>
									</li>
																					</ul>
					</div>
				</nav>
				<div class="backdrop"></div>
			</div>
		</div>
		<div class="container opaque hidden-md-down"  style="opacity:0">
			<div class="bottom container">
				<div class="row">
					<div class="left-side col-md-4">
						<section class="date-wrapper">
							June 24th, 2022						</section>
					</div>
					<div class="middle-side col-md-4">
						<section class="logo-wrapper">
							<a class="logo" href="/">
																	<img src="https://cdispatch.com/wp-content/themes/commercial_dispatch/img/dispatch_blk.png">
																<p class="tagline">
									Open eyes, open minds.
								</p>
							</a>
						</section>
					</div>
					<div class="right-side col-md-4">
						<section class="weather-wrapper">
						<i class="sw"></i>
                                <span class="temp-imperial"></span>
						</section>
					</div>
				</div>
			</div>
		</div>
		</header>
						<div class="breaking-news">
					<div class="container">
						<a href="https://cdispatch.com/best">
							<!--<span class="breaking-news-title">BREAKING NEWS &#45;</span>--><div class="breaking-news-descript">VOTE NOW: Best of the Triangle</div>
						</a>
					</div><!-- end container -->
				</div><!-- end breaking news -->
			

	<div class="add leaderboard"><aside id="bs_zones-11" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="84553" keywords="not_home_page,not_landing_page,is_article_page,college-sports,sports,sports,mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside></div>
	<style>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</style>
<style>
.wp-caption-text{
    font-family: "Noto Sans",sans-serif;
    color: #989595;
    font-size: 11px;
    padding-top:5px;
}
#admiralContent.paywall {
    position:relative;
    height:160px;
    overflow:hidden;
}
#admiralContent.paywall::before {
    content: '';
    background: linear-gradient(rgba(255, 255, 255, 0), rgba(255, 255, 255, 0.5), rgb(255, 255, 255));
    top: 0;
    bottom: 0;
    left: 0;
    right: 0;
    z-index: 10;
    position: absolute;
}

#paywallBox {
    margin-top:2rem;
    padding: 1rem;
}
.subscribe-link {
    background-color: #cf1117;
    border: 0;
    border-radius: 1px;
    color: #FFF;
    font-size: 15px;
    font-weight: 700;
    padding: 8px 22px;
    transition: 300ms background-color ease;
    text-decoration: none;
}
.login-subscribe {
	display:flex;
	align-items:center;
}

.mobile-login-subscribe {
	justify-content: space-between;
}

.mobile-login-subscribe .sign-in-link,
.mobile-login-subscribe .subscribe-link{
	display:block;
}
.mobile-login-subscribe .sign-in-link {
	padding:0;
}
</style>
<script>
	    jQuery(document).on('ready', function() {
			// VARIABLES
			var isSafari = /^((?!chrome|android).)*safari/i.test(navigator.userAgent),
			    setScrollClasses = function() {
					var $header = jQuery('header'),
						mobile = window.innerWidth < 992,
						headerScrollLimit = mobile ? 55 : 55;//800;


					if (mobile) {

					}

					if (window.scrollY >= headerScrollLimit) {
						jQuery('body').addClass('_sticky');
						$header.addClass('scrolled');
					} else {
						jQuery('body').removeClass('_sticky');
						$header.removeClass('scrolled');
					}
				}, fixWeather = function() {
					window.setTimeout(function() {
						jQuery('.mobile-bottom .weather-wrapper').html(jQuery('.bottom .weather-wrapper').html());
					}, 2000);
				}, fixSafari = function() {
                   jQuery('body').addClass('safari');
				};

			// EVENT LISTENERS
            jQuery('.hamburger-toggle').on('click', function(e) {
				e.preventDefault();

                jQuery('body, header, .sections-menu, .hamburger-toggle, .quickview-menu').toggleClass('sections-menu-open');
			});
			jQuery('.backdrop').on('click', function(e) {
				jQuery('body, header, .sections-menu, .hamburger-toggle, .quickview-menu').removeClass('sections-menu-open')
			});
			jQuery(window).on('scroll', setScrollClasses);
			jQuery(window).on('resize', setScrollClasses);

            // INIT
			setScrollClasses();
			fixWeather();

			if (isSafari) {
			    fixSafari();
			}
		});
	</script>
<style>
.single-width {
        width:100%;
        max-width:1200px;
}
.single-thumb img {
        width:100%;
}
</style>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/lity/2.4.1/lity.min.css" integrity="sha512-UiVP2uTd2EwFRqPM4IzVXuSFAzw+Vo84jxICHVbOA1VZFUyr4a6giD9O3uvGPFIuB2p3iTnfDVLnkdY7D/SJJQ==" crossorigin="anonymous" />
<div class="container content-margin clearfix">
        <div class="row">
		<div class="col-md-7 col-lg-8 col-xl-9 featured-col">
			
                                                <!-- sub cats menu -->
                                                <div class="archive-menu" style="padding-bottom:2rem;"><ul><li><a href="https://cdispatch.com/sports/">Sports</a></li><li><a href="https://cdispatch.com/sports/college-sports/">College Sports</a></li></ul></div>
                        <div class="single-width">
								<style>
#admiralContent broadstreet-zone {
	padding: 0 !important;
	margin-bottom: 20px;
}
</style>
<article class="post-205400 post type-post status-publish format-standard has-post-thumbnail hentry category-college-sports category-sports" id="post-205400">
	<h1 class="single-title">Mississippi State guard Iverson Molinar not selected in NBA draft</h1>	<h2 class="secondary-headline">
    Molinar left Bulldogs after strong junior season    </h2>	
	
	<h4 class="single-author">
By <span class="author-link"><a href="https://cdispatch.com/author/theo-derosa/" title="Posts by Theo DeRosa" rel="author">Theo DeRosa</a></span> &#149; 2 hours ago  
</h4>	


		<div class="single-thumb">
		<img width="640" height="426" src="https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10.jpg" class="attachment-large size-large wp-post-image" alt="" srcset="https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10.jpg 1024w, https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10-300x200.jpg 300w, https://cdispatch.com/wp-content/uploads/2022/06/Perryman-Molinar-v-SC-3-10-768x512.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" />	</div>
		

		<div class="image-caption">
		Iverson Molinar was not selected in Thursday's NBA draft. The junior guard left Mississippi State after averaging 17.5 points during the 2021-22 season. Photo by: Austin Perryman/Mississippi State athletics	</div>
		
	<div class="entry-content">
		<div id="admiralContent">
			<p>Iverson Molinar hoped to parlay a strong junior season at Mississippi State into a professional draft selection.


<p>But Molinar’s decision to leave school early didn’t pay off.


<p>At least, not in Thursday’s NBA draft, in which the Panamanian guard went unselected. Molinar’s exclusion was no surprise — he was expected to go undrafted — but slim hopes of sneaking into the late second round went unfulfilled.


<p>Molinar declared for the draft while maintaining his collegiate eligibility on March 25 and signed with an agent a month later, forgoing his remaining time in maroon and white.

</p><div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1444394249'><broadstreet-zone place="0" callback="zone_load_1444394249" zone-id="84554" keywords="not_home_page,not_landing_page,is_article_page,college-sports,sports,sports,mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_1444394249 = function(z, d) { if (!d.count) document.getElementById('zone_load_1444394249').style.display = 'none'; };</script>


<p>He led Mississippi State with 17.5 points per game — good for third in the Southeastern Conference — while averaging 3.6 assists and 3.1 rebounds per contest.


<p>A once-reliable 3-point shot escaped Molinar entirely last season, as he shot just 25.2 percent from deep. During his sophomore season, Molinar connected on 43.6 percent of his attempts from 3.


<p>Still, Molinar was a reliable scoring presence for the Bulldogs. He reached double figures in all 34 games as Mississippi State went 18-16 and lost in the first round of the NIT.


<p>He became the second MSU guard to leave school early but go undrafted in as many seasons. D.J. Stewart Jr. did the same last year in a move lamented by coach Ben Howland, who was fired after the 2021-22 season.


<p>Molinar was one of eight scholarship players to leave Starkville after Howland’s firing. Six entered the transfer portal (D.J. Jeffries and Shakeel Moore did as well but chose to return to MSU) and forward Garrison Brooks also chose to turn pro after exhausting his eligibility. Brooks was not selected in Thursday’s draft.


<p>With two years of eligibility remaining, Molinar could have returned as the Bulldogs’ lead guard and star player under new coach Chris Jans. Instead, he’ll be looking for a home as an undrafted free agent or overseas.


		
			<div class="sidebar-section-title">
        	        	<div class="red-border"></div>
       			</div>
			<p><em>Theo DeRosa reports on Mississippi State sports for The Dispatch. Follow him on Twitter at @Theo_DeRosa.</em></p>			<div class="heateor_sss_sharing_container heateor_sss_horizontal_sharing" data-heateor-ss-offset="0" data-heateor-sss-href='https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/'><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcdispatch.com%2Fsports%2F2022-06-23%2Fmississippi-state-guard-iverson-molinar-not-selected-in-nba-draft%2F%3Fsrc%3Drss" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=Mississippi%20State%20guard%20Iverson%20Molinar%20not%20selected%20in%20NBA%20draft&url=https%3A%2F%2Fcdispatch.com%2Fsports%2F2022-06-23%2Fmississippi-state-guard-iverson-molinar-not-selected-in-nba-draft%2F%3Fsrc%3Drss" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_email" onclick="window.open('mailto:?subject=' + decodeURIComponent('Mississippi%20State%20guard%20Iverson%20Molinar%20not%20selected%20in%20NBA%20draft' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fcdispatch.com%2Fsports%2F2022-06-23%2Fmississippi-state-guard-iverson-molinar-not-selected-in-nba-draft%2F%3Fsrc%3Drss' ), '_blank')" title="Email" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#649a3f;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 43 43"><path d="M 5.5 11 h 23 v 1 l -11 6 l -11 -6 v -1 m 0 2 l 11 6 l 11 -6 v 11 h -22 v -11" stroke-width="1" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_printfriendly" href="https://www.printfriendly.com/print?url=https%3A%2F%2Fcdispatch.com%2Fsports%2F2022-06-23%2Fmississippi-state-guard-iverson-molinar-not-selected-in-nba-draft%2F%3Fsrc%3Drss&partner=a2a" title="PrintFriendly" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_printfriendly" style="background-color:#61d1d5;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><g stroke="#fff" stroke-width="1.5" stroke-linecap="round" stroke-miterlimit="10"><path fill="none" d="M22.562 19.588v4.373H9.438v-4.37h13.124zm-13.124 1.53H6.375c-.483 0-.875-.313-.875-.7v-7.35c0-.387.392-.7.875-.7h19.25c.482 0 .875.313.875.7v7.35c0 .387-.393.7-.876.7h-3.062"></path><path fill="#fff" d="M22.562 12.32V8.04H9.436v4.28"></path></g></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:35px;height:35px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://cdispatch.com/sports/2022-06-23/mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft/?src=rss', 'Mississippi%20State%20guard%20Iverson%20Molinar%20not%20selected%20in%20NBA%20draft', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div>		</div>
	
		<style>
.image-wrap {
	margin-bottom:2rem;
}
.image-wrap img {
width:100%;
}

.slider{
	max-width:750px;
}
.slider .image-caption {
        margin:.5rem 0 1rem;
}
</style>
 
			</div><!-- .entry-content -->

</article><!-- #post-## -->

                                			</div>
                </div><!-- end col 9 -->
                <div id="sidebar" class="col-md-5 col-lg-4 col-xl-3">
                         
<style>
.sidebar-section {
	border:none;
	padding-bottom:0;
	margin-bottom:0;
}
.sidebar-box {
        margin-bottom:2rem;
}
.sidebar-links ul {
        margin:0;
        padding: 0;
        list-style-position: inside;
}
</style>

<div class="sidebar-section clearfix">
<div class="sidebar-inner">
	<h2 class="sidebar-section-title">
		<div class="red-border"></div>
		<a href="/popular-content/">Popular</a>
	</h2>
						<div class="art-wrap-side">
			<div class="container sidebar-container">
				<a href="https://cdispatch.com/sports/2022-06-22/mississippi-state-football-tries-something-different-with-new-balconies-at-davis-wade-stadium/">
					<h2 class="art-title-side">
						Mississippi State football tries ‘something different’ with new Balconies at Davis Wade Stadium					</h2>
					<h3 class="art-author-side">
						By <span class="author-link">Theo DeRosa</span>					</h3>
				</a><!-- end permalink -->
			</div><!-- end container-->
		</div><!-- end art wrap side -->
			<div class="art-wrap-side">
			<div class="container sidebar-container">
				<a href="https://cdispatch.com/news/2022-06-22/dog-park-removed-from-george-evans-park-plans/">
					<h2 class="art-title-side">
						Dog park removed from George Evans Park plans					</h2>
					<h3 class="art-author-side">
						By <span class="author-link">Violet Jira</span>					</h3>
				</a><!-- end permalink -->
			</div><!-- end container-->
		</div><!-- end art wrap side -->
			<div class="art-wrap-side">
			<div class="container sidebar-container">
				<a href="https://cdispatch.com/news/2022-06-22/columbus-native-organized-rallies-travel-for-trump/">
					<h2 class="art-title-side">
						Columbus native organized rallies, travel for Trump					</h2>
					<h3 class="art-author-side">
						By <span class="author-link">Caroline Beach</span>					</h3>
				</a><!-- end permalink -->
			</div><!-- end container-->
		</div><!-- end art wrap side -->
			<div class="art-wrap-side">
			<div class="container sidebar-container">
				<a href="https://cdispatch.com/news/2022-06-22/shs-principal-leaving-for-job-on-coast/">
					<h2 class="art-title-side">
						SHS principal leaving for job on coast					</h2>
					<h3 class="art-author-side">
						By <span class="author-link">Jessica Lindsey</span>					</h3>
				</a><!-- end permalink -->
			</div><!-- end container-->
		</div><!-- end art wrap side -->
	
        <div class="add right-1"><aside id="bs_zones-10" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="84555" keywords="not_home_page,not_landing_page,is_article_page,college-sports,sports,sports,mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside></div>

	<br>
	
	
        <div class="sidebar-box sidebar-links">
                <h2 class="section-title">
                        <div class="red-border"></div>
                        Public Information Links                </h2>

                <div class="art-wrap-side">
                        <div class="container sidebar-container art-title-side">
                                <ul>
<li><a href="https://www.thecityofcolumbusms.org/">City of Columbus</a></li>
<li><a href="https://lowndescountyms.com/">Lowndes County</a></li>
<li><a href="https://www.cityofstarkville.org/">City of Starkville</a></li>
<li><a href="http://www.oktibbehacountyms.org/">Oktibbeha County</a></li>
<li><a href="http://www.wpnet.org/">City of West Point</a></li>
<li><a href="http://www.claycountyms.com/">Clay County</a></li>
<li><a href="https://cdispatch.com/public-records/building-permits/">Building Permits</a></li>
<li><a href="https://cdispatch.com/public-records/marriages-divorces/">Marriages &amp; Divorces</a></li>
<li><a href="https://msdh.ms.gov/msdhsite/_static/43,1911,231,203.html">MS Dept of Health Restaurant Inspections</a></li>
</ul>
                        </div>
                </div>
        </div>

        


	


	<div class="add right-2"><aside id="bs_zones-9" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="84556" keywords="not_home_page,not_landing_page,is_article_page,college-sports,sports,sports,mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside></div>	<br><br>


	<h2 class="section-title">
                <div class="red-border"></div>
                On This Day 2021        </h2>
                                                        <div class="art-wrap-side">
                        <div class="container sidebar-container">
                                <div class="row">
                                                <div class="col-5">
                                                        <a href="https://cdispatch.com/news/2021-06-24/j5-to-end-partnership-with-columbus-june-30/">
                                                        <img width="775" height="592" src="https://cdispatch.com/wp-content/uploads/2021/06/Edwards-Jabari-this.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://cdispatch.com/wp-content/uploads/2021/06/Edwards-Jabari-this.jpg 775w, https://cdispatch.com/wp-content/uploads/2021/06/Edwards-Jabari-this-300x229.jpg 300w, https://cdispatch.com/wp-content/uploads/2021/06/Edwards-Jabari-this-768x587.jpg 768w" sizes="(max-width: 775px) 100vw, 775px" />                                                        </a>
                                                </div><!--end col 5 -->
                                                <div class="col-7" style="padding:0px;">
                                                        <a href="https://cdispatch.com/news/2021-06-24/j5-to-end-partnership-with-columbus-june-30/">
                                                                <h2 class="art-title-side">
                                                                        J5 to end partnership with Columbus June 30                                                                </h2>
                                                        </a>
                                                        <h3 class="art-author-side">
                                                                By <span class="author-link">Isabelle Altman</span>                                                        </h3>
                                                </div><!-- end col 7 -->
                                </div><!-- end row -->
                        </div><!-- end container -->
                </div><!-- end art wrap side -->
        

	<h2 class="section-title">
	<div class="red-border"></div>
		Featured Podcast
	</h2>
	<a href="https://www.buzzsprout.com/645052" target="_blank">
		<img src="https://cdispatch.com/wp-content/uploads/2021/03/podcast-promo-bullybanter.png" alt="The C Dispatch Podcast">
	</a>
	<br><br>
	<div class="add right-3"><aside id="bs_zones-8" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="84557" keywords="not_home_page,not_landing_page,is_article_page,college-sports,sports,sports,mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside></div>	</div><!-- end sidebar section -->
</div><!-- end sidebar section -->
                </div><!-- end col 3 -->
        </div><!-- end row -->
</div><!--container -->
<script src="https://cdnjs.cloudflare.com/ajax/libs/lity/2.4.1/lity.min.js" integrity="sha512-UU0D/t+4/SgJpOeBYkY+lG16MaNF8aqmermRIz8dlmQhOlBnw6iQrnt4Ijty513WB3w+q4JO75IX03lDj6qQNA==" crossorigin="anonymous"></script>



<footer>
    <div class="top container-fluid">
	    <div class="container">
			<div class="row">
				<div class="sections-menu-wrapper col-6 col-md-2">
				    <div class="redline"></div>
					<h3 class="footer-title">
						Sections
					</h3>
					<h3 class="footer-tab">
						<div class="menu-footer-sections-container"><ul id="menu-footer-sections" class="menu"><li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-117"><a href="https://cdispatch.com/news/">News</a></li>
<li id="menu-item-120" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-120"><a href="https://cdispatch.com/sports/">Sports</a></li>
<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119"><a href="https://cdispatch.com/opinions/">Opinions</a></li>
<li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116"><a href="https://cdispatch.com/lifestyles/">Lifestyles</a></li>
<li id="menu-item-338" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-338"><a href="https://cdispatch.com/obituaries/">Obituaries</a></li>
</ul></div>					</h3>
				</div>
			    <div class="info-menu-wrapper col-6 col-md-2">
			        <div class="redline"></div>
					<h3 class="footer-title">
						Info
					</h3>
					<h3 class="footer-tab">
						<div class="menu-footer-info-container"><ul id="menu-footer-info" class="menu"><li id="menu-item-128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128"><a href="https://cdispatch.com/about/">About</a></li>
<li id="menu-item-127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-127"><a href="https://cdispatch.com/contact/">Contact</a></li>
<li id="menu-item-183388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183388"><a href="https://cdispatch.com/tips/">Submit a Tip</a></li>
<li id="menu-item-123" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-123"><a href="https://cdispatch.com/terms-service/">Terms &#038; Service</a></li>
<li id="menu-item-122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122"><a href="https://cdispatch.com/popular-content/">Popular Content</a></li>
</ul></div>					</h3>
				</div>
				<div class="d-logo-wrapper col-6 col-md-5">
					<img src="/wp-content/themes/commercial_dispatch/img/dispatch--red-d-logo-2.png" alt="Dispatch">
				</div>
				<div class="contact-us-wrapper col-6 col-md-3">
					<div class="redline"></div>
					<h3 class="footer-title">
						Contact Us
					</h3>
					<h3 class="footer-tab">
						<div class="info-block">
							<p class="title">Main Switchboard:</p>
                            <p class="info"><a style="text-decoration: underline; color:#cf1117;" href="tel:"(662) 328-2424" target="_blank">(662) 328-2424</a></p>
						</div>
						<div class="info-block">
							<p class="title">Physical Address:</p>
                            <p class="info">516 Main Street<br>Columbus, MS 39701</p>
						</div>
						<div class="info-block">
							<p class="title">Mailing Address:</p>
                            <p class="info">PO Box 511<br>Columbus, MS 39701</p>
                        </div>
					</h3>
                </div>
			</div>
		</div>
	</div>
    <div class="bottom container-fluid">
	    <div class="container">
			<div class="row footer-row">
			    <div class="social-wrap col-12 col-md-3">
					<a href="https://www.facebook.com/TheDispatch/" class="social-a" target="_blank">
						<div class="social-icon">
							<i class="fab fa-facebook-f"></i>
						</div>
					</a>
					<a href="https://www.instagram.com/cdispatch/?hl=en" class="social-b" target="_blank">
						<div class="social-icon">
							<i class="fab fa-instagram"></i>
						</div>
					</a>
					<a href="https://twitter.com/cdispatch" class="social-c" target="_blank">
						<div class="social-icon">
							<i class="fab fa-twitter"></i>
						</div>
					</a>
				</div>
				<div class="copyright col-12 col-md-6">
					<p>cdispatch.com &#169; 2022 <span class="copy-divider">&#8211;</span> <span>The Commerical Dispatch</span></p>
				</div>
				<div class="col-item newsletter col-12 col-md-3 email-form">
					<form class="form-inline" action="https://cdispatch.us1.list-manage.com/subscribe/post?u=e81b340d15eee79f9f4f56d93&amp;id=8ec11fcf47" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate>

					  <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="Enter E-mail for Newsletter">
					  <button type="submit">Sign Up</button>
					</form>
				</div>
			</div>
		</div>
	</div>
	<!--template detection<div><strong>Current template:</strong> single.php</div>-->
</footer>
<script>
  jQuery(document).ready(function($) {
    $('body').show();
  });
</script>
<style>
	footer {
		background: #f9f9f9;
		background: -moz-linear-gradient(top,#f9f9f9 0,#ecd5d5 100%);
		background: -webkit-linear-gradient(top,#f9f9f9 0,#ecd5d5 100%);
		background: -webkit-gradient(linear,left top,left bottom,from(#f9f9f9),to(#ecd5d5));
		background: -o-linear-gradient(top,#f9f9f9 0,#ecd5d5 100%);
		background: linear-gradient(to bottom,#f9f9f9 0,#ecd5d5 100%);
		font-family: "Noto Sans", sans-serif;
		margin-top: 80px;
		min-height: 483px;
		width: 100%;
	}
	footer .top {
        padding: 60px 0 30px;
	}
	@media (min-width: 768px) {
		footer .top {
			padding: 100px 0 50px;
		}
	}
	footer .top .sections-menu-wrapper {
		margin-bottom: 40px;
	}
	@media (min-width: 768px) {
		footer .top .sections-menu-wrapper {
			margin-bottom: 0;
		}
	}
	footer .top .info-menu-wrapper {
		margin-bottom: 40px;
	}
	@media (min-width: 768px) {
		footer .top .info-menu-wrapper {
			margin-bottom: 0;
		}
	}
	footer .top .d-logo-wrapper {
		text-align: left;
	}
	@media (min-width: 768px) {
		footer .top .d-logo-wrapper {
		    text-align: right;
	    }
	}
	footer .top .d-logo-wrapper img {
		margin: 0px 30px 0 0;
		max-width: 35%;
		height: auto;
	}
	@media (max-width: 768px) {
		footer .top .d-logo-wrapper img {
		margin: 0px 30px 0 0;
		max-width: 75%;
		height: auto;
	}
	}
	footer .top .contact-us-wrapper .info-block {
	}
	footer .top .contact-us-wrapper .info-block .title {
		font-weight: bold;
		font-size: 15px;
		line-height: 20px;
		margin-bottom: 0;
	}
	footer .top .contact-us-wrapper .info-block .info {
		font-size: 15px;
		line-height: 20px;
	}
	footer .top .footer-title {
        margin-bottom: 15px;
	}
	footer .top .footer-tab {
		margin: 0;
		padding: 0;
		text-align: left;
	}
	footer .top .footer-tab ul {
		list-style-type: none;
		margin: 0;
		padding: 0;
	}
	footer .top .footer-tab ul li {
		line-height: 20px;
		margin: 0;
	}
	footer .top .footer-tab ul li a {
		color: #000;
		font-weight: bold;
		font-size: 15px;
		text-align: left;
	}
	footer .bottom {
		background-color: #cf1117;
	}
	footer .bottom .social-wrap {
		display: flex;
		justify-content: center;
		order: 1;
		padding:0;
	}
	.footer-row{
		padding:30px 0;
		align-items: center;
	}
	.email-form {
		margin:0;
	}
	@media (min-width: 768px) {
		footer .bottom .social-wrap {
			display: block;
		}
	}
	footer .bottom .social-wrap .social-icon {
		margin: 1px auto;
	}
	footer .bottom .copyright {
		display: flex;
		justify-content: center;
		margin-top: 0;
		order: 3;
	}
	footer .bottom .copyright span {
		display:inline-block;
	}
	@media (min-width: 768px) {
		footer .bottom .copyright {
			order: 2;
		}
	}
	footer .bottom .copyright p {
		color: #fff;
		font-size: 14px;
		margin: 0;
		text-align: center;
	}
	footer .bottom .newsletter {
		display: flex;
		justify-content: center;
		order: 2;
	}
	@media (min-width: 768px) {
		footer .bottom .newsletter {
			justify-content:right;
		}
	}
	footer .bottom .newsletter a {
		background-color: #FFF;
		border: 0;
		border-radius: 1px;
		box-shadow: 1px 1px 5px 0px rgba(0, 0, 0, 0.28);
		color: #000;
		display: inline-block;
		font-size: 13px;
		font-weight: bold;
		margin-top: 38px;
		padding: 12px 24px;
		white-space: nowrap;
	}
	@media (max-width: 767px) {
		.footer-row {
			padding: 40px 0;
		}
		.footer-row .col-item {
			padding:40px 0;
		}
	}
	@media (max-width: 409px) {
		footer .bottom .copyright span {
                	display:block;
        	}
		footer .bottom .copyright span.copy-divider {
			display:none;
		}
	}
</style>
<!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span><div class="cli-bar-container cli-style-v2"><div class="cli-bar-message">We use cookies on our website to give you the most relevant experience by remembering your preferences and repeat visits. By clicking “Accept”, you consent to the use of ALL the cookies.</div><div class="cli-bar-btn_container"><a role='button' class="cli_settings_button" style="margin:0px 10px 0px 5px">Cookie settings</a><a role='button' data-cli_action="accept" id="cookie_action_close_header" class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button wt-cli-accept-btn" style="display:inline-block">ACCEPT</a></div></div></span></div><div id="cookie-law-info-again" style="display:none" data-nosnippet="true"><span id="cookie_hdr_showagain">Manage consent</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
	<div class="cli-modal-content cli-bar-popup">
		  <button type="button" class="cli-modal-close" id="cliModalClose">
			<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
			<span class="wt-cli-sr-only">Close</span>
		  </button>
		  <div class="cli-modal-body">
			<div class="cli-container-fluid cli-tab-container">
	<div class="cli-row">
		<div class="cli-col-12 cli-align-items-stretch cli-px-0">
			<div class="cli-privacy-overview">
				<h4>Privacy Overview</h4>				<div class="cli-privacy-content">
					<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may affect your browsing experience.</div>
				</div>
				<a class="cli-privacy-readmore" aria-label="Show more" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a>			</div>
		</div>
		<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
												<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
								Necessary							</a>
															<div class="wt-cli-necessary-checkbox">
									<input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
									<label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
								</div>
								<span class="cli-necessary-caption">Always Enabled</span>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="necessary">
								<div class="wt-cli-cookie-description">
									Necessary cookies are absolutely essential for the website to function properly. These cookies ensure basic functionalities and security features of the website, anonymously.
<table class="cookielawinfo-row-cat-table cookielawinfo-winter"><thead><tr><th class="cookielawinfo-column-1">Cookie</th><th class="cookielawinfo-column-3">Duration</th><th class="cookielawinfo-column-4">Description</th></tr></thead><tbody><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checbox-analytics</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookie is used to store the user consent for the cookies in the category "Analytics".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checbox-functional</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">The cookie is set by GDPR cookie consent to record the user consent for the cookies in the category "Functional".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checbox-others</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookie is used to store the user consent for the cookies in the category "Other.</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-necessary</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookies is used to store the user consent for the cookies in the category "Necessary".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">cookielawinfo-checkbox-performance</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">This cookie is set by GDPR Cookie Consent plugin. The cookie is used to store the user consent for the cookies in the category "Performance".</td></tr><tr class="cookielawinfo-row"><td class="cookielawinfo-column-1">viewed_cookie_policy</td><td class="cookielawinfo-column-3">11 months</td><td class="cookielawinfo-column-4">The cookie is set by the GDPR Cookie Consent plugin and is used to store whether or not user has consented to the use of cookies. It does not store any personal data.</td></tr></tbody></table>								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="functional" data-toggle="cli-toggle-tab">
								Functional							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-functional" class="cli-user-preference-checkbox"  data-id="checkbox-functional" />
									<label for="wt-cli-checkbox-functional" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Functional</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="functional">
								<div class="wt-cli-cookie-description">
									Functional cookies help to perform certain functionalities like sharing the content of the website on social media platforms, collect feedbacks, and other third-party features.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="performance" data-toggle="cli-toggle-tab">
								Performance							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-performance" class="cli-user-preference-checkbox"  data-id="checkbox-performance" />
									<label for="wt-cli-checkbox-performance" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Performance</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="performance">
								<div class="wt-cli-cookie-description">
									Performance cookies are used to understand and analyze the key performance indexes of the website which helps in delivering a better user experience for the visitors.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="analytics" data-toggle="cli-toggle-tab">
								Analytics							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-analytics" class="cli-user-preference-checkbox"  data-id="checkbox-analytics" />
									<label for="wt-cli-checkbox-analytics" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Analytics</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="analytics">
								<div class="wt-cli-cookie-description">
									Analytical cookies are used to understand how visitors interact with the website. These cookies help provide information on metrics the number of visitors, bounce rate, traffic source, etc.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="advertisement" data-toggle="cli-toggle-tab">
								Advertisement							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-advertisement" class="cli-user-preference-checkbox"  data-id="checkbox-advertisement" />
									<label for="wt-cli-checkbox-advertisement" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Advertisement</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="advertisement">
								<div class="wt-cli-cookie-description">
									Advertisement cookies are used to provide visitors with relevant ads and marketing campaigns. These cookies track visitors across websites and collect information to provide customized ads.
								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="others" data-toggle="cli-toggle-tab">
								Others							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-others" class="cli-user-preference-checkbox"  data-id="checkbox-others" />
									<label for="wt-cli-checkbox-others" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Others</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="others">
								<div class="wt-cli-cookie-description">
									Other uncategorized cookies are those that are being analyzed and have not been classified into a category as yet.
								</div>
							</div>
						</div>
					</div>
										</div>
	</div>
</div>
		  </div>
		  <div class="cli-modal-footer">
			<div class="wt-cli-element cli-container-fluid cli-tab-container">
				<div class="cli-row">
					<div class="cli-col-12 cli-align-items-stretch cli-px-0">
						<div class="cli-tab-footer wt-cli-privacy-overview-actions">
						
															<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE &amp; ACCEPT</a>
													</div>
						
					</div>
				</div>
			</div>
		</div>
	</div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all--><link rel='stylesheet' id='cookie-law-info-table-css'  href='https://cdispatch.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-table.css?ver=2.1.2' media='all' />
<script src='https://cdispatch.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script src='https://cdispatch.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.13.1' id='jquery-ui-datepicker-js'></script>
<script id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script src='https://cdispatch.com/wp-content/themes/commercial_dispatch/js/theme.min.js?ver=.1617941202' id='understrap-scripts-js'></script>
<script src='https://cdispatch.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://cdispatch.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://cdispatch.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://cdispatch.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script src='https://cdispatch.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.38' id='heateor_sss_sharing_js-js'></script>

        <div class="add impact"><aside id="bs_zones-21" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="84549" keywords="not_home_page,not_landing_page,is_article_page,college-sports,sports,sports,mississippi-state-guard-iverson-molinar-not-selected-in-nba-draft,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside></div>
<script>
        jQuery(document).ready(function($) {
                //$.ajaxSetup({ cache:false });
    $.ajax({
        url: '/weather.json',
		type: 'get',
		cache:false,
        dataType: 'json',
        success: function(response){
                var current_temp = Math.round(response.main.temp);
                var weather_id   = response.weather[0].id;
		setWeather(weather_id, current_temp);
		}
	});

	function setWeather(weather_id, current_temp) {
		$('.temp-imperial').empty().append(current_temp);
		$('.sw').addClass('sw-owm-' + weather_id);
	}
        });


 document.addEventListener("DOMContentLoaded", function(){
	 initial_navbar_height = document.querySelector('#main-header').offsetHeight;
	 jQuery('body').attr('data-navbar-height', initial_navbar_height);
	 var timer = null;
	    window.addEventListener('scroll', function() {
	if(timer !== null) {
        clearTimeout(timer);        
    }var navbar_offset = 0;//jQuery('#main-header').offset().top;
    timer = setTimeout(function() {	  
      if (window.scrollY > navbar_offset) {
        document.getElementById('main-header').classList.add('fixed-top');
        // add padding top to show content behind navbar
        navbar_height = jQuery('body').data('navbar-height');// document.querySelector('#main-header .top').offsetHeight;
        document.body.style.paddingTop = navbar_height + 'px';
      } else {
        document.getElementById('main-header').classList.remove('fixed-top');
         // remove padding top from body
        document.body.style.paddingTop = '0';
      }
	    }, 0);
}, false);
 });

</script>
<script src="https://cdn.jsdelivr.net/npm/js-cookie@2/src/js.cookie.min.js"></script>
<script>
jQuery(document).ready(function($) {
    var signInButton   = $(".sign-in-link");
    var subscribeBtn   = $(".subscribe-link");
    var paywallContent = $("#admiralContent");

    var logoutAccount  = '<a class="sign-in-link subscribed" href=""><i class="fas fa-user"></i> My Account</a>';
    var loginSubscribe = ' <a class="sign-in-link" href=""><i class="fas fa-user"></i>Sign In</a><a class="subscribe-link" href="/subscribe/">Subscribe</a>';
    var isSubscriber   = Cookies.get('dispatch_subscriber');
   
    $('body').on('click', '.admiral-subscribe', function($) {
        window.admiral('show','transact.subscribe',{offerID:'6059e701da6fa9463248f7fb'})
        e.prevenDefault();
    });

    $('body').on('click', '.sign-in-link', function(e) {
	if ( $(this).hasClass('subscribed') ) {
	    window.admiral('show','transact.manage');
	} else {
            window.admiral('show','transact.login');   
	}	    	
	e.preventDefault();
    });

    if ( isSubscriber ) {
	$('.login-subscribe').empty().append(logoutAccount);
    } else {
	$('.login-subscribe').empty().append(loginSubscribe);
    }

    window.admiral('after', 'transact.loggedIn', function() {
	$('.login-subscribe').empty().append(logoutAccount);
        Cookies.set('dispatch_subscriber', true);
    });

    window.admiral("after", "transact.loggedOut", function() {
        $('.login-subscribe').empty().append(loginSubscribe);
    	Cookies.remove('dispatch_subscriber');
    });
    
});
</script>
</body>

</html>

